Mailinglist Archive: opensuse-buildservice (269 mails)

< Previous Next >
Re: [opensuse-buildservice] rsibreak compile problem
  • From: Dirk Müller <dmueller@xxxxxxx>
  • Date: Thu, 4 Sep 2008 17:40:54 +0200
  • Message-id: <200809041740.58066.dmueller@xxxxxxx>
On Thursday 04 September 2008, Peter Czanik wrote:

So, here is my next problem: soprano. It requires 'java-devel'. On PPC
there are three packages providing this:
java-1_5_0-gcj-compat-devel
java-1_6_0-openjdk-devel
java-1_7_0-icedtea-devel
Which should be used? The first problem was, that compilation failed, as
the BS could not choose from these. I added the following line to the
project config:

I believe we should try to get it to build with openjdk, as thats the one we
use for the other architectures.

As this seemed to be the most stable Java implementation on PPC. It did
not work as expected, as configure says:
-- Could not find Java JNI

Yep, I also know about that failure :) I unfortunately haven't had time to find
a fix yet, but my guess is that $JAVA_HOME in the spec file is really wrong.


Greetings,
Dirk
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >