Mailinglist Archive: opensuse-buildservice (269 mails)

< Previous Next >
Re: [opensuse-buildservice] rsibreak compile problem
  • From: Peter Czanik <pczanik@xxxxxxxxxxxxxx>
  • Date: Thu, 04 Sep 2008 17:26:33 +0200
  • Message-id: <48BFFE29.7060903@xxxxxxxxxxxxxx>
Hello,

Dirk Müller írta:
Yes, I know about the problem already. for other compile problems of KDE packages, please use the opensuse-kde@xxxxxxxxxxxx mailinglist.
OK, I'm here :-) First a little introduction: I'm building KDE 4.1 for PPC in a local BS for openSUSE 11.0. I already posted a related bug to the BS list, and was redirected here...

So, here is my next problem: soprano. It requires 'java-devel'. On PPC there are three packages providing this:
java-1_5_0-gcj-compat-devel
java-1_6_0-openjdk-devel
java-1_7_0-icedtea-devel
Which should be used? The first problem was, that compilation failed, as the BS could not choose from these. I added the following line to the project config:
Prefer: java-1_6_0-openjdk-devel
As this seemed to be the most stable Java implementation on PPC. It did not work as expected, as configure says:
-- Could not find Java JNI
And at the end there were some missing files.
For now I worked around this by editing out the java dependent parts of the spec file, so I could compile the rest of the packages in the repo. But obviously I'd like to know, what would be a proper solution, which java-devel is used on x86, etc.
Bye,
CzP
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups