Mailinglist Archive: opensuse-buildservice (250 mails)

< Previous Next >
Re: [opensuse-buildservice] confused buildrequires?
  • From: Wolfgang Rosenauer <wolfgang@xxxxxxxxxxxxx>
  • Date: Fri, 22 Aug 2008 15:33:22 +0200
  • Message-id: <48AEC022.4010902@xxxxxxxxxxxxx>

Ruediger Oertel schrieb:
On Wednesday 20 August 2008 11:01:08 Wolfgang Rosenauer wrote:

I just noticed that seamonkey fails to build on most distributions with
expansion errors:

"nothing provides myspell-dictionary"

So first thing is that didn't fail in the past and another thing is why
does it fail at all?

I only have
PreReq: myspell-dictionary
in a sub-package and
%triggerin -- myspell-dictionary
%triggerpostun -- myspell-dictionary

ah, interesting ...
well, in order to be able to test-install a package after build (we already
do this in the internal systems), we had to add the PreReq(ed) packages
to the build-environment. As this was not done before, the expansion error
did never show up.
This means you are building in a project/repository where no package satisfies
this dependency. However no idea why that is happening ...

That certain PreReq was a bit bogus anyway (aka not really needed IIRC).
I have another package where it causes an expansion error where I think
OBS is on fault.
has an error on SLES9:
nothing provides shared-mime-info needed by MozillaFirefox
nothing provides desktop-file-utils needed by MozillaFirefox

I've tried to fix it by:
%if %suse_version > 910
PreReq: shared-mime-info desktop-file-utils

But it still fails with the same error. Does the PreReq parser ignore
%if statements?

To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups