Mailinglist Archive: opensuse-buildservice (351 mails)

< Previous Next >
Re: [opensuse-buildservice] Error in dependencies on RHEL, Fedora and Cent_OS
  • From: Christian Boltz <opensuse@xxxxxxxxx>
  • Date: Mon, 14 Jul 2008 23:11:35 +0200
  • Message-id: <200807142311.41806@xxxxxxxxxxxxxxx>
Hello,

on Montag, 14. Juli 2008, G. Massera wrote:
I created a package named "yarp" that compiles well on RHEL, Fedora
and Cent_OS.
Then, I created a package that depends on yarp... and in spec I
write: "BuildRequires: yarp"
but then... the Build Service doesn't start the compilation because
it tell me:

"Nothing provides perl(yarp) required by yarp"

What does it means ??

It means what it says: The package "yarp" requires "perl(yarp)", which
means a perm module with filename "yarp.pm" (or "use yarp;" in perl) +
a "Provides: perl(yarp)" in the package containing it.

If the yarp package contains the yarp.pm file, just add the Provides: to
the specfile.
Otherwise find or create a package containing the perl module ;-)


Regards,

Christian Boltz
--
Never let a computer know you're in a hurry.
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
References