Mailinglist Archive: opensuse-buildservice (238 mails)

< Previous Next >
Re: [opensuse-buildservice] local obs problem - packages are notpublishedafter build
  • From: Adrian Schröter <adrian@xxxxxxx>
  • Date: Tue, 27 May 2008 07:19:56 +0200
  • Message-id: <200805270719.56696.adrian@xxxxxxx>
Am Montag 26 Mai 2008 22:57:46 schrieb Christian:

yes NFS-share is a problem.
tried without NFS-share and everything works well. Then I tried to mount
NFS-share for /srv/obs/repos and after that package is build, can remove
files, but not add the new build ones, and then the package gets rebuild
and rebuild and rebuild.
For testing i gave "obsrun" a shell, die su - obsrun and tried to
write/delete on the NFS-share without any problem. So I can not
understand why does not work.

share is exported as following
/srv/obs/repos obs(rw,sync,no_root_squash)

and mounted via fstab:
hades:/srv/obs/repos /srv/obs/repos nfs

You need /repos and /build on the same volume, because the files get hard

If you want to upload to /repos data to a remote server, you can do so by
defining a rsync upload in the

To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >