Mailinglist Archive: opensuse-buildservice (239 mails)

< Previous Next >
Re: [opensuse-buildservice] Expansion error, which I can'texplain.:-(
  • From: Michal Marek <mmarek@xxxxxxx>
  • Date: Tue, 06 May 2008 21:37:00 +0200
  • Message-id: <4820B35C.2050603@xxxxxxx>
Stefan Dirsch napsal(a):
Works, but now avr-libc/avr-gdb cannot decide any longer to chose
between libmpfr1 and mpfr (cross-avr-gcc requires libmpfr.so.1). I
added a seconde Substitute line

Substitute: mpfr libmpfr1

to the project, but this didn't help. How can I force avr-libc/avr-gdb
to use libmpfr1? Do I need to patch avr-libc/avr-gdb specfile and add
a 'Requires: libmpfr1'? Seems so. :-(

Prefer: libmpfr1

Substitute: overwrites manual (Build)Requires in spec files before
build, whereas this is an automatic dependency on libmpfr.so.1 I guess.

Michal
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >