Mailinglist Archive: opensuse-buildservice (219 mails)

< Previous Next >
Re: [opensuse-buildservice] _aggregate from _link
  • From: Jeffery Fernandez <jeffery@xxxxxxxxxx>
  • Date: Thu, 21 Feb 2008 08:27:57 +1100
  • Message-id: <200802210827.57829.jeffery@xxxxxxxxxx>
ok its my stuff up. I created the aggregate file within the package I was
building.

I should have been creating a separate package in my home project for the
aggregate I linked against. All good now.

P.S. Thought I replied to this yesterday, but it seems I replied to myself!

cheers,
Jeffery

On Wed, 20 Feb 2008 12:27:26 pm Jeffery Fernandez wrote:
Hi all,

I am trying to build with an aggregated package from:

<aggregate project="home:dstoecker">
<package>ocaml</package>
</aggregate>

that package is _linked from project=openSUSE:Factory

When I add a BuildRequires : ocaml = 3.10.0

It just does not build as it complains with:
expansion error: nothing provides ocaml = 3.10.0

If I remove the version number dependency, it pulls out ocaml-3.09.3-37
into the build environment which I assume is coming from
project=openSUSE:Factory

So my question is if it is possible to build with an aggregate package
which is _linked from an other project?

regards,
Jeffery Fernandez



--
Internet Vision Technologies
Level 1, 520 Dorset Road
Croydon
Victoria - 3136
Australia
web: http://www.ivt.com.au
phone: +61 3 9723 9399
fax: +61 3 9723 4899
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
References