Mailinglist Archive: opensuse-buildservice (219 mails)

< Previous Next >
[opensuse-buildservice] build a package locally using "build" and bs-packagecache
  • From: Wolfgang Rosenauer <wolfgang@xxxxxxxxxxxxx>
  • Date: Mon, 11 Feb 2008 15:16:59 +0100
  • Message-id: <47B058DB.2030605@xxxxxxxxxxxxx>

I've tried to build a package on my local system using "build" and reusing the bs-packagecache as RPM repository.

That fails most probably because these ugly directory names containing ':'.

build --root=/var/tmp/build-root cairo.spec --norootforbuild --rpms /local/build/bs-packagecache/openSUSE\:10.3/standard/x86_64

fails to find the RPMs there.
I guess I tried every type of quoting for the colon but everything failed.
To see if it's really the colon I've created a symlink w/o a colon to that directory and there it works.

Worth a bugreport against build?

To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >