Mailinglist Archive: opensuse-buildservice (170 mails)

< Previous Next >
Re: [opensuse-buildservice] apache2-devel replacement for Fedora
  • From: Plinnell <mrdocs@xxxxxxxxxxxx>
  • Date: Tue, 4 Dec 2007 18:45:44 +0100
  • Message-id: <200712041845.45222.mrdocs@xxxxxxxxxxxx>
On Tuesday 04 December 2007 14:12:06 Christian Boltz wrote:
Hello,

on Montag, 3. Dezember 2007, Cristian Rodríguez wrote:
Christian Boltz escribió:
Does someone know which package I need to use instead as
BuildRequires?

httpd-devel

Thanks, that is what I needed.
Unfortunately httpd-devel is Apache 1.x, so a mapping wouldn't be really
useful because I have to call apxs instead of apxs2.


Try httpd2-devel


(Webpin for all distros in the buildservice would be quite useful...)

I ended up with a %if section:

%if %{defined fedora_version}
BuildRequires: httpd-devel
%define serverroot %(/usr/sbin/apxs -q datadir 2>/dev/null ||
/usr/sbin/apxs -q PREFIX)/htdocs/
%else
BuildRequires: apache2-devel
%define serverroot %(/usr/sbin/apxs2 -q datadir 2>/dev/null ||
/usr/sbin/apxs2 -q PREFIX)/htdocs/
Recommends: postfix
Suggests: php-pgsql
%endif


Fedora's RPM also doesn't understand Recommends and Suggests :-(
Is it possible that the buildservice strips these tags automatically?


Those need to be ifdef's in the spec file.


Regards,

Christian Boltz

HTH,

Peter

---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups