Mailinglist Archive: opensuse-buildservice (366 mails)

< Previous Next >
Re: [opensuse-buildservice] Factory java-devel expansion error
  • From: Ales Nosek <anosek@xxxxxxx>
  • Date: Mon, 20 Aug 2007 15:08:50 +0200
  • Message-id: <46C99262.2080208@xxxxxxx>
Hi Adrian,

thanks for your effort but the problem still exists. Please, look at
Java:jpackage-1.7 project. There are lots of packages that don't build
due to expansion errors.
Thank you

Ales


Adrian Schröter wrote:
> On Wednesday 15 August 2007 11:03:48 wrote Adrian Schröter:
>   
>> On Wednesday 15 August 2007 10:37:30 wrote Ruediger Oertel:
>>     
>>> On Wed, 15 Aug 2007, Adrian Schröter wrote:
>>>       
>>>> Hi,
>>>>
>>>> On Tuesday 14 August 2007 19:10:56 wrote Ales Nosek:
>>>>         
>>>>> Hi Adrian,
>>>>>
>>>>> I'm getting:
>>>>>
>>>>> SUSE_Factory expansion error
>>>>> have choice for java-devel: java-1_4_2-cacao-devel
>>>>> java-1_4_2-gcj-compat-devel
>>>>>
>>>>>
>>>>> please, could you make java-1_4_2-gcj-compat-devel package default
>>>>> when expanding java-devel dependency?
>>>>> I maintain some packages in BS and also in Autobuild and I don't
>>>>> won't to edit the BuildRequires every time.
>>>>>           
>>>> Sure, this should not happen. However, we do not handle java-devel in
>>>> any special way neither in OBS nor in autobuild configs.
>>>>         
>>> yes we do. Actually not "java-devel", but the packages providing that
>>> tag by having "negative prefer settings" for some of the java*
>>> packages. But for OBS the one with no "negative prefer" is not present
>>> (java-1_5_0-sun-devel), so the group of the rest gives an ambiguity.
>>>
>>> Adrian: can you remove this line from the OBS config:
>>>       
>> okay, excluded by an "%if ! 0%opensuse_bs " statement now.
>>
>> It is right, we have a difference for binary only (and that hits mainly
>> java) packages atm. We should clean this up after 10.3 release via the
>> proposed three repositories / build trees ...
>>     
>
> please note that you have still a difference with this. The OBS does use now 
> the gcj enviroment and not Sun Java 1.5 when building.
>
> Build against Java:Sun-Java-1.5 project if you do not want this.
>
> bye
> adrian
>
>
>   

---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >