Mailinglist Archive: opensuse-buildservice (181 mails)

< Previous Next >
[opensuse-buildservice] strange results from 'abuild' on SUSE 10.0 only?
  • From: John Pye <john@xxxxxxxxxxxxxxxxxx>
  • Date: Tue, 03 Jul 2007 22:30:54 +1000
  • Message-id: <468A417E.9070708@xxxxxxxxxxxxxxxxxx>
Hi all

I have a C library package that builds perfectly well on FC5 through 7,
openSUSE 10.2 and Factory, and Mandriva 2006.

The package fails strangely on SUSE 10.0, however, with a message from
'abuild', as follows, below. Despite what the message says, the spec
file *does* have a %description, and this error is not thrown on any
other distro.

I have seen problems like this with the Build Service in other cases. It
seems like the parsing of the spec file that abuild does might have some
bugs in certain cases. In the past I was able to (trivially) rearrange
my spec file and make it work, however I am less willing to do that now
that my package builds correctly in all these other distros.

Any thoughts or suggestions?

Cheers
JP

|-----------------------------------------------------------------
----- building sundials.spec (user abuild)
-----------------------------------------------------------------
-----------------------------------------------------------------
error: parse error in expression
error: /usr/src/packages/SOURCES/sundials.spec:17:
parseExpressionBoolean returns -1
error: Package has no %description: sundials

|
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >