Mailinglist Archive: opensuse-buildservice (193 mails)

< Previous Next >
[opensuse-buildservice] RFC: osc support for SLES9 / Python 2.3
  • From: "Dr. Peter Poeml" <poeml@xxxxxxx>
  • Date: Wed, 25 Apr 2007 22:05:11 +0200
  • Message-id: <20070425200510.GV4538@xxxxxxx>
SLES9 ships with Python 2.3. With my latest code changes, I noticed that
I changed things in a way incompatible to Python 2.3 (using decorators).

(I basically noticed this because byte-compiling failed according to the
build log, although the build didn't actually fail due to that. I saw it
by pure luck.)

This can easily be fixed, so I removed the decorators and started to
test osc on SLES9, and found more problems on the way. 

Python 2.3 didn't have a cookielib module, and it is not easy to add it
because parts of it live integrated in the urllib2 module. Still, it is
straightforward to just skip cookie support if not available.

But there were further problems, which prevent the current codebase from
working with Python 2.3. I fixed some further issues, and got as far as
to a working 'osc build'.

However, the next problem I'm facing is that I can't commit files (gets
an internal server error back), and since urllib2 is not as easy to
debug as newer versions, I stopped there for now.

Overall, the situation gives me the impression that osc hasn't been
working on SLES9 lately, or maybe since a long time, and nobody did ever
complain about it.

The download statistics show 6 or 7 osc package downloads in the
last 50 days for SLES9.

What do you think. Is it worth pursuing this further? Or should we maybe
simply no longer build osc for SLES9?

All other platforms in the buildservice seem to have Python 2.4 or
newer.

Peter
-- 
Allen Gewalten zum Trutz sich erhalten.
 
SUSE LINUX Products GmbH
Research & Development
< Previous Next >
This Thread
  • No further messages