Mailinglist Archive: opensuse-buildservice (193 mails)

< Previous Next >
Re: [opensuse-buildservice] Upgrading compat-g77 for openSUSE 10.2 ?
  • From: Tobias Burnus <burnus@xxxxxxxx>
  • Date: Thu, 05 Apr 2007 10:29:12 +0200
  • Message-id: <4614B358.2020803@xxxxxxxx>
Hi,

David Cournapeau schrieb:
> I am starting compiling some FORTRAN libraries with the build system,
> and I am using g77 as provided by the package compat-g77 for the
> openSUSE 10.2 distribution. Unfortunately, there was a fatal bug in
> this package when openSUSE was released, bug which was solved some
> time ago: on my test openSUSE machine, I can compile the software fine
> (release 42 of the compat-g77 package, vs release 38 on the build
> service).
Is there a reason for not using gfortran (gcc-fortran)? This is a
Fortran 77/90/95 compiler which is actively maintained. Starting with
GCC 4.0 it has replaced g77. If there is a problem with gfortran, I'm
very interested in knowing what it is.

Note g77 is part only of the unmaintained GCC 3.x compiler and will not
be developed further. (Not that SUSE won't fix bugs such as the one in
the bugreport you quote below.)

> https://bugzilla.novell.com/show_bug.cgi?id=218406
Well, if you read the bugreport you find:

approved for 10.2 update:        MaintenanceTracker-7958


Tobias,
who is one of the gfortran maintainers (at GCC)
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
References