Mailinglist Archive: opensuse-buildservice (295 mails)

< Previous Next >
Re: [opensuse-buildservice] Cannot use `build` tool to build openssh-4.4p1-24 rpm on SuSE10.2
  • From: Michael Schroeder <mls@xxxxxxx>
  • Date: Mon, 12 Mar 2007 17:41:28 +0100
  • Message-id: <20070312164128.GA995@xxxxxxx>
On Mon, Mar 12, 2007 at 12:17:40PM -0400, Hung Lin wrote:
> I tried to create openssh-4.4p1-24 rpm on SuSE10.2 machine. I used the
> `build` tool and here's the command I ran:
> test124:~/suse_build/openssh-4.4p1-24 # build --rpms /mnt/10.2/
> openssh.spec
> logging output to /var/tmp/build-root/.build.log...
> test124 started "build openssh.spec" at Mon Mar 12 12:11:47 EDT 2007.
> Using BUILD_ROOT=/var/tmp/build-root
> Using BUILD_RPMS=/mnt/10.2/
> Using BUILD_ARCH=i586:i486:i386
> processing specfile /root/suse_build/openssh-4.4p1-24/openssh.spec...
> init_buildsystem openssh.spec ...
> expanding package dependencies...
> expansion error
> have choice for syslog needed by openct: syslogd syslog-ng
> It seems it cannot resolve the dependencies of the required rpms. The
> thing I don't understand is that I removed all packages in
> "usedforbuild" line and ran the same command again, it still showed the
> same error messages. I tried to use `build` tool to build
> hello-2.1.1-343 and it works fine.

It seems to use the wrong config file. /usr/lib/build/configs/sl10.2.conf
should include the line
sl10.2.conf:Ignore: openct:syslog
if that's not true, your build.rpm is too old. What version of build are
you using?


Michael Schroeder mls@xxxxxxx
SUSE LINUX Products GmbH, GF Markus Rex, HRB 16746 AG Nuernberg
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >