Mailinglist Archive: opensuse-buildservice (295 mails)

< Previous Next >
[opensuse-buildservice] Cannot use `build` tool to build openssh-4.4p1-24 rpm on SuSE10.2
  • From: "Hung Lin" <hlin@xxxxxxxxxxx>
  • Date: Mon, 12 Mar 2007 12:17:40 -0400
  • Message-id: <8812D8156467224C9E9739E513037EF1036D22D2@xxxxxxxxxxxxxxxxx>
Hi,

I tried to create openssh-4.4p1-24 rpm on SuSE10.2 machine. I used the
`build` tool and here's the command I ran:

test124:~/suse_build/openssh-4.4p1-24 # build --rpms /mnt/10.2/
openssh.spec
logging output to /var/tmp/build-root/.build.log...
test124 started "build openssh.spec" at Mon Mar 12 12:11:47 EDT 2007.

Using BUILD_ROOT=/var/tmp/build-root
Using BUILD_RPMS=/mnt/10.2/
Using BUILD_ARCH=i586:i486:i386

processing specfile /root/suse_build/openssh-4.4p1-24/openssh.spec...
init_buildsystem openssh.spec ...
expanding package dependencies...
expansion error
have choice for syslog needed by openct: syslogd syslog-ng



It seems it cannot resolve the dependencies of the required rpms. The
thing I don't understand is that I removed all packages in
"usedforbuild" line and ran the same command again, it still showed the
same error messages. I tried to use `build` tool to build
hello-2.1.1-343 and it works fine.



Thank you very much for your time.



Hung Lin
Software Engineer
NexTone Communications, Inc.

-- Network Without Limits --
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups