Mailinglist Archive: opensuse-buildservice (354 mails)

< Previous Next >
Re: [opensuse-buildservice] Failed to add repository from build service
  • From: Adrian Schröter <adrian@xxxxxxx>
  • Date: Thu, 8 Feb 2007 11:26:18 +0100
  • Message-id: <200702081126.19108.adrian@xxxxxxx>
Am Donnerstag 08 Februar 2007 10:28:10 schrieb Dirk Stoecker:
> Hello,
>
> I failed to add OpenSUSE build service repositories to two different
> OpenSUSE 10.2 servers.
>
> repositories are "home:dstoecker" and "science"
>
> Attached is a y2log I tried with following URL
> ftp://ftp.gwdg.de/pub/opensuse/repositories/home:/dstoecker/openSUSE_10.2
>
> It seems there are some problems with the key file. I had no trouble to
> add the same source on my desktop system with OpenSUSE10.2. The only
> difference is that the 2 servers have no desktop system installed and I
> used yast commandline version (thought there should be no difference
> between GUI and commandline version, shouldn't it).
>
> The question are:
> - is that a build-service problem
> - is this an yast problem I should report for openSUSE10.2
>
> Additional note: Had no problem on a 10.1 server.


It is not a bug, it is a feature ...

YaST in 10.2 does validate the repository meta data, which means that it
accepts only repositories which are signed with an accept key. When you
import the key into the rpm database, it should get accepted.

Klaus, are there any plans to make this easier for the user ?

bye
adrian

--

Adrian Schroeter
SUSE Linux Products GmbH, Maxfeldstr. 5, 90409 Nuernberg, Germany
email: adrian@xxxxxxx

---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References