Mailinglist Archive: opensuse-buildservice (354 mails)

< Previous Next >
Re: [opensuse-buildservice] Re: Webclient running locally
  • From: Dirk Stoecker <opensuse@xxxxxxxxxxxx>
  • Date: Wed, 7 Feb 2007 17:32:52 +0100 (CET)
  • Message-id: <Pine.LNX.4.64.0702071720220.9491@xxxxxxxxxxxxxxxxx>
On Tue, 6 Feb 2007, Adrian Schröter wrote:

> > I'm still not able to run the webclient locally and accessing the build
> > service on api.opensuse.org.
> >
> > Any help would be fine. Can't patch it if I can't run it.
>
> You shave a look in /srv/www/obs/webclient/log/ , maybe you can see what
> wents wrong. Or post a relevant snippet here.

Reading the post by "Rafal Kwasny" I asume api.opensuse.org port 80 is
correct. Well then there error lays here:

> > > 80 is not supported, as server redirects to https are the result.

I started wireshark to watch the I/O data stream. So I see what goes
out and in:

The first thing the interface tries to do is load http://api.opensuse.org/person/dstoecker

So let's try this also:

> wget http://api.opensuse.org/person/dstoecker
--17:28:43-- http://api.opensuse.org/person/dstoecker
=> `dstoecker'
Auflösen des Hostnamen »api.opensuse.org«.... 195.218.123.20
Verbindungsaufbau zu api.opensuse.org|195.218.123.20|:80... verbunden.
HTTP Anforderung gesendet, warte auf Antwort... 302 Found
Platz: https://api.opensuse.org/person/dstoecker[folge]

As you can see, instead of an answer a 302 redirect is sent. This results
in wrongly interpreted data, ... If you want I can attach the error
messages, but I think the problem is clear.

Server configuration changed inbetween?

Ciao
--
http://www.dstoecker.eu/ (PGP key available)
< Previous Next >