Mailinglist Archive: opensuse-buildservice (253 mails)

< Previous Next >
Re: [opensuse-buildservice] Other Platforms than (open)SUSE in BS
  • From: Michael Schroeder <mls@xxxxxxx>
  • Date: Fri, 17 Nov 2006 16:15:41 +0100
  • Message-id: <20061117151541.GA19848@xxxxxxx>
On Fri, Nov 17, 2006 at 08:41:32PM +0530, Jigish Gohil wrote:
> We are using the following in our repository, you can check those specs out.
>
> %if "%_repository" == "SUSE_Linux_10.1" || "%_repository" == "SLE_10"
> BuildRequires: xorg-x11-compat70-devel
> %endif
> %if "%_repository" != "SUSE_Linux_10.0"
> BuildRequires: libdrm-devel
> %endif

This makes it hard for people that import your package and use
different repository names. I think it's better to use

%if 0%{?suse_version} >= 1010
BuildRequires: xorg-x11-compat70-devel
%endif
%if 0%{?suse_version} != 1000
BuildRequires: libdrm-devel
%endif

Cheers,
Michael.

--
Michael Schroeder mls@xxxxxxx
main(_){while(_=~getchar())putchar(~_-1/(~(_|32)/13*2-11)*13);}
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups