Mailinglist Archive: opensuse-buildservice (257 mails)

< Previous Next >
Re: [opensuse-buildservice] iChain switch succeeded :)
  • From: Stefan Dirsch <sndirsch@xxxxxxx>
  • Date: Fri, 13 Oct 2006 11:49:50 +0200
  • Message-id: <20061013094950.GA12548@xxxxxxx>
On Fri, Oct 13, 2006 at 10:36:30AM +0200, Stefan Dirsch wrote:
> On Fri, Oct 13, 2006 at 10:28:08AM +0200, Adrian Schröter wrote:
> > Am Friday 13 October 2006 10:06 schrieb Stefan Dirsch:
> > > On Fri, Oct 13, 2006 at 09:45:35AM +0200, Stefan Dirsch wrote:
> > > > On Thu, Oct 12, 2006 at 05:54:56PM +0200, Adrian Schröter wrote:
> > > > > the build service now runs via iChain. This means that you need to use
> > > > > your bugzilla/www.opensuse.org password from now on.
> > > > >
> > > > > The command line users need also to update the osc tool to version 0.9
> > > > > to get access to it again.
> > > >
> > > > Unfortunately this doesnn't work for me, e.g.
> > > >
> > > > sndirsch@shannon:~/pkgs/openSUSE/games:action/xmoto> osc ci
> > > > Error: can't get 'http://api.opensuse.org/source/games:action/xmoto'
> > > > HTTP Error 400: Bad Request
> > > >
> > > > I'm using osc-0.9-5.1. Latest changelog entry.
> > > >
> > > > * Do Okt 12 2006 - poeml@xxxxxxx
> > > > - update to 0.9 (r761):
> > > > [...]
> > > >
> > > > user/pass in ~/.oscrc is set correctly.
> > > >
> > > > osc st/diff work. Anyone, who can reproduce this problem?
> > >
> > > Since adding/removing/editing files via the BS website works I think
> > > this is an osc issue.
> >
> > Does it help to add
> >
> > scheme: https
> >
> > in ~/.oscrc below the [general] section ?
>
> Not at all. :-( My ~/.oscrc:
>
> [general]
>
> # Downloaded packages are cached here. Must be writable by you.
> #packagecachedir = /var/tmp/osbuild-packagecache
>
> # Wrapper to call build as root (sudo, su -, ...)
> #su-wrapper = su -c
>
> # rootdir to setup the chroot environment
> # can contain %(repo)s and/or %(arch)s for replacement
> #build-root = /var/tmp/build-root
>
> # use this API server
> # (it needs a section [api.opensuse.org] with the credentials)
> #apisrv = api.opensuse.org
> scheme: https
>
> [api.opensuse.org]
> user = sndirsch
> pass = XXXXXXXXXXX
>
> > Peter, can you make https to be the default ?
>
> Looks like he already did, but this version doesn't work either for
> me. :-(

The problem is limited to machine 'shannon' and/or the current
(python?) packages from STABLE.

Best regards,
Stefan

Public Key available
------------------------------------------------------
Stefan Dirsch (Res. & Dev.) SUSE LINUX Products GmbH
Tel: 0911-740 53 0 Maxfeldstraße 5
FAX: 0911-740 53 479 D-90409 Nürnberg
http://www.suse.de Germany
------------------------------------------------------
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups