Mailinglist Archive: opensuse-buildservice (252 mails)

< Previous Next >
Re: [opensuse-buildservice] Subversion
  • From: "Dr. Peter Poeml" <poeml@xxxxxxx>
  • Date: Tue, 19 Sep 2006 12:24:20 +0200
  • Message-id: <20060919102420.GC11239@xxxxxxx>
On Tue, Sep 19, 2006 at 11:22:20AM +0200, Marco Abeln wrote:
> Am Dienstag, 19. September 2006 11:14 schrieb Dr. Peter Poeml:
> > On Tue, Sep 19, 2006 at 11:08:00AM +0200, Marco Abeln wrote:
> > > Hi all,
> > >
> > > I am very happy, that I can find the new Subversion Release at the
> > > BuildService, but why can I find only the newest Version (1.4.0)? IsnĀ“t
> > > there an opinion to get older Version from there? I need the Version
> > > before 1.4.0 (1.3.2) for SLES9.
> >
> > Care to explain why?
> Because when the update crashes, I can downgrade Subversion to the working
> Version.
> safety first :)

Then if you upgrade, do so after a period of time which makes you feel safe.

For a fresh install, I'm sorry I cannot offer backup copies at the
moment. But the way I maintain the subversion project is that it always
contains stable packages. They already run on our internal sles9 svn
server, if that helps you ;)

It would be a theoretical option to maintain two subversion projects,
one just to keep a known-to-work-well version available, but in the last
2 or 3 years this was not necessary, neither for apache nor for
subversion packages, partly (I hope) because I took great care to not
break anything.

However, there is no garantuee.

But everybody is welcome to help in promptly identifing and fixing
problems, and this is what actually happens. I would like to invite you
to participate.

Regards,
Peter

PS. Of course you are free to archive packages for later.

--
SUSE LINUX Products GmbH Bug, bogey, bugbear, bugaboo:
Research & Development A malevolent monster (not true?);
Some mischief microbic;
What makes someone phobic;
The work one does not want to do.
From: Chris Young (The Omnificent English Dictionary In Limerick Form)
< Previous Next >