Mailinglist Archive: opensuse-buildservice (156 mails)

< Previous Next >
Re: [opensuse-buildservice] Xgl build fails for factory
  • From: Stefan Dirsch <sndirsch@xxxxxxx>
  • Date: Mon, 14 Aug 2006 16:19:22 +0200
  • Message-id: <20060814141922.GA29445@xxxxxxx>
On Mon, Aug 14, 2006 at 06:27:11PM +0530, Jigish Gohil wrote:
> On 8/14/06, Stefan Dirsch <sndirsch@xxxxxxx> wrote:
> >On Sun, Aug 13, 2006 at 02:28:38PM +0530, Jigish Gohil wrote:
> >> Here is the error with which it exits.
> >>
> >> checking if gcc -E requires -undef... gcc: no input files
> >> gcc: no input files
> >> configure: error: gcc -E defines unix with or without -undef. I don't
> >> know what to do.
> >> error: Bad exit status from /var/tmp/rpm-tmp.46657 (%build)
> >>
> >> I see the same error in xorg7 project too.
> >>
> >> Any suggestions?
> >
> >Yes, since this does not happen in STABLE for autobuild (STABLE="SUSE
> >internal Factory") this needs to be investigated with a local osc
> >build, but I never did such a local build before. :-(
>
> If that is so, I can only hope it will get fixed with the build
> service's next sync with the factory tree.

Not really.

Short version: put cpp in your BuildRequires
Long version:
- cpp is missing, therefore "gcc -E" is used instead for ${RAWCPP}
- unfortunately "gcc -E < input_file" does *not* work, whereas
"cpp < input_files" does

Conclusion:
- Bug in autotools?
- Wrong package expansion for buildservice Factory?

Best regards,
Stefan

Public Key available
------------------------------------------------------
Stefan Dirsch (Res. & Dev.) SUSE LINUX Products GmbH
Tel: 0911-740 53 0 Maxfeldstraße 5
FAX: 0911-740 53 479 D-90409 Nürnberg
http://www.suse.de Germany
------------------------------------------------------
---------------------------------------------------------------------
To unsubscribe, e-mail: opensuse-buildservice+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-buildservice+help@xxxxxxxxxxxx

< Previous Next >
This Thread
Follow Ups