Mailinglist Archive: opensuse-buildservice (156 mails)

< Previous Next >
[opensuse-buildservice] FreeRADIUS build error
  • From: Peter Nixon <listuser@xxxxxxxxxxxxxx>
  • Date: Wed, 2 Aug 2006 14:24:59 +0300
  • Message-id: <200608021425.04883.listuser@xxxxxxxxxxxxxx>
Hi Guys

When I build FreeRADIUS on the openSUSE Build Service I get the following
errors scattered throughout the build (On all SUSE versions) but the build
continues, but doesnt make anu .so files.


/usr/src/packages/BUILD/freeradius-1.1.2/libtool --mode=link gcc -release
1.1.2 \
-module -export-dynamic -o rlm_eap_tls.la \
-rpath /usr/lib/freeradius rlm_eap_tls.lo
rlm_eap_tls.c /usr/src/packages/BUILD/freeradius-1.1.2/src/lib/libradius.la \
../../libeap/libeap.la -lcrypto -lssl -lcrypto -lnsl -lresolv -lpthread
rm -fr .libs/rlm_eap_tls.la .libs/rlm_eap_tls.* .libs/rlm_eap_tls-1.1.2.*

*** Warning: This library needs some functionality provided by -lcrypto.
*** I have the capability to make that library automatically link in when
*** you link to this library. But I can only do this if you have a
*** shared version of the library, which you do not appear to have.

*** Warning: This library needs some functionality provided by -lssl.
*** I have the capability to make that library automatically link in when
*** you link to this library. But I can only do this if you have a
*** shared version of the library, which you do not appear to have.

*** Warning: This library needs some functionality provided by -lcrypto.
*** I have the capability to make that library automatically link in when
*** you link to this library. But I can only do this if you have a
*** shared version of the library, which you do not appear to have.

*** Warning: This library needs some functionality provided by -lnsl.
*** I have the capability to make that library automatically link in when
*** you link to this library. But I can only do this if you have a
*** shared version of the library, which you do not appear to have.

*** Warning: This library needs some functionality provided by -lresolv.
*** I have the capability to make that library automatically link in when
*** you link to this library. But I can only do this if you have a
*** shared version of the library, which you do not appear to have.

*** Warning: This library needs some functionality provided by -lpthread.
*** I have the capability to make that library automatically link in when
*** you link to this library. But I can only do this if you have a
*** shared version of the library, which you do not appear to have.

*** Warning: libtool could not satisfy all declared inter-library
*** dependencies of module rlm_eap_tls. Therefore, libtool will create
*** a static module, that should work as long as the dlopening
*** application is linked with the -dlopen flag.
ar cru .libs/rlm_eap_tls.a rlm_eap_tls.o
ranlib .libs/rlm_eap_tls.a

When I build locally I dont get the same errors so, does anyone know what
dependency I am missing on the build service?

I currently specify (plus base system):

BuildRequires: cyrus-sasl-devel
BuildRequires: db-devel
BuildRequires: e2fsprogs-devel
BuildRequires: gcc-c++
BuildRequires: gdbm-devel
BuildRequires: gettext-devel
BuildRequires: glibc-devel
BuildRequires: libtool
BuildRequires: mysql-devel
BuildRequires: ncurses-devel
BuildRequires: openldap2-devel
BuildRequires: openssl-devel
BuildRequires: pam-devel
BuildRequires: perl
BuildRequires: postgresql-devel
BuildRequires: python-devel
BuildRequires: sed
BuildRequires: unixODBC-devel
BuildRequires: zlib-devel

I think it could be something to do with FreeRADIUS's older version of libtool
and fakeroot or chroot which I believe the buildservice uses.

Does anyone have any idea on how to (easily) fix this problem?

TIA

--

Peter Nixon
http://www.peternixon.net/
PGP Key: http://www.peternixon.net/public.asc

-------------------------------------------------------

--

Peter Nixon
http://www.peternixon.net/
PGP Key: http://www.peternixon.net/public.asc
< Previous Next >
This Thread
  • No further messages