Mailinglist Archive: opensuse-buildservice (197 mails)

< Previous Next >
[opensuse-buildservice] Re: Buggy net-snmp on 64bit machines
  • From: Peter Nixon <listuser@xxxxxxxxxxxxxx>
  • Date: Fri, 16 Jun 2006 14:32:05 +0300
  • Message-id: <200606161432.12615.listuser@xxxxxxxxxxxxxx>
On Fri 16 Jun 2006 14:23, Marcus Rueckert wrote:
> On 2006-06-16 14:18:44 +0300, Peter Nixon wrote:
> > The net-snmp service included with SUSE 10.0 incorrectly returns 64bit
> > integers for 32bit counters on the AMD64 platform. (I spent several weeks
> > trying to figure out why my NMS system could not correctly monitor my new
> > SunFire servers)
>
> bug report for this?
> do you have example queries which are broken?

If you do an snmpwalk of the mib nothing crashes, however OpenNMS verbosely
logs ASN parser buffer overflow messages and fails to correctly monitor the
host. If you want I can dig deeper into this, but it is fixed in 5.3.0.1 so I
don't really see the need.

> > Updating net-snmp to net-snmp-5.3.0.1-36.2 available from the OpenSUSE
> > net-snmp project (http://software.opensuse.org/download/net-snmp/) solves
> > the problem, but this then breaks PHP and a number of other SNMP related
> > apps.
>
> Of course. the soname changed iirc.
>
> > Is there any chance of an official net-snmp update for SL-10.0 to fix
> > this problem or am I going to have to recompile php myself?
>
> open a bugreport for this and wait to get it fixed.
> or install 10.1 ;) 10.1 ships with 5.3.0.1.

Thanks.. I am happily running Factory on my notebook, but 10.1 is still a bit
erm.. "new" for my servers. A couple more weeks or a month and I might
consider starting to deploy it, but at that time I hope SLES10 will be out
and I will use it. SLES9 is just a little bit to old for some of my
deployments which is why I am running 10.0.. The rest of course run SLES9 as
you would expect.

Cheers

--

Peter Nixon
http://www.peternixon.net/
PGP Key: http://www.peternixon.net/public.asc
< Previous Next >
Follow Ups