Mailinglist Archive: opensuse-bugs (6588 mails)

< Previous Next >
[Bug 1143632] New: varnish lacks default config
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Wed, 31 Jul 2019 12:45:23 +0000
  • Message-id: <bug-1143632-21960@http.bugzilla.novell.com/>
http://bugzilla.novell.com/show_bug.cgi?id=1143632


Bug ID: 1143632
Summary: varnish lacks default config
Classification: openSUSE
Product: openSUSE Distribution
Version: Leap 15.1
Hardware: x86-64
OS: Other
Status: NEW
Severity: Minor
Priority: P5 - None
Component: Installation
Assignee: yast2-maintainers@xxxxxxx
Reporter: laurent.henry@xxxxxxxx
QA Contact: jsrain@xxxxxxxx
Found By: ---
Blocker: ---

A fresh install of varnish can not start.

service varnish start

systemd[1]: varnish.service: Failed to load environment files: No such file or
directory
systemd[1]: varnish.service: Failed to run 'start' task: No such file or
directory
systemd[1]: Failed to start Varnish HTTP accelerator/reverse proxy.

Here is the default content of /usr/lib/systemd/system/varnish.service

[Unit]
Description=Varnish HTTP accelerator/reverse proxy
After=network.target

[Service]
EnvironmentFile=/etc/sysconfig/varnish
PIDFile=/var/run/varnishd.pid
ExecStart=/usr/sbin/varnishd $VARNISHD_PARAMS -P /var/run/varnishd.pid -F
[Install]
WantedBy=multi-user.target


/etc/sysconfig/varnish does not exist
touch /etc/sysconfig/varnish is sufficient.
By the way, i don't know yet if nothing is missing to varnish later.
As an example, i don't know where is initialized this $varnishd_params too

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >
This Thread
  • No further messages