Mailinglist Archive: opensuse-bugs (6588 mails)

< Previous Next >
[Bug 1143550] New: libvirt: Error starting domain: Requested operation is not valid: network 'default' is not active every time workstation is rebooted
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Wed, 31 Jul 2019 07:29:40 +0000
  • Message-id: <bug-1143550-21960@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=1143550


Bug ID: 1143550
Summary: libvirt: Error starting domain: Requested operation is
not valid: network 'default' is not active every time
workstation is rebooted
Classification: openSUSE
Product: openSUSE Distribution
Version: Leap 15.1
Hardware: Other
OS: Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Basesystem
Assignee: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
Reporter: pstivanin@xxxxxxxx
QA Contact: qa-bugs@xxxxxxx
Found By: ---
Blocker: ---

Since the upgrade from Leap 15.0 to Leap 15.1, I get the following error when
spawning a VM from virt-manager:

Error starting domain: Requested operation is not valid: network 'default' is
not active
Traceback (most recent call last):
File "/usr/share/virt-manager/virtManager/asyncjob.py", line 75, in
cb_wrapper
callback(asyncjob, *args, **kwargs)
File "/usr/share/virt-manager/virtManager/asyncjob.py", line 111, in tmpcb
callback(*args, **kwargs)
File "/usr/share/virt-manager/virtManager/libvirtobject.py", line 66, in
newfn
ret = fn(self, *args, **kwargs)
File "/usr/share/virt-manager/virtManager/domain.py", line 1422, in startup
self._backend.create()
File "/usr/lib64/python3.6/site-packages/libvirt.py", line 1089, in create
if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirt.libvirtError: Requested operation is not valid: network 'default' is
not active

How to reproduce (not sure if it's really reproducible, I don't have a spare
bare metal host to try it):
* install leap 15.0
* set up some vms using virt-manager
* update to leap 15.1
* shutdown workstation and turn it on again
* open virt-manager, right click on a vm and then "run"
* the popup error appears

Workaround:
sudo virsh net-start default

As you can see the network should start on boot:
$ sudo virsh net-info default
Name: default
UUID: 4d29642d-c3bf-4e69-98a3-2edcf4f66aed
Active: no
Persistent: yes
Autostart: yes
Bridge: virbr0

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >
Follow Ups