Mailinglist Archive: opensuse-bugs (6588 mails)

< Previous Next >
[Bug 1143125] systemd-vconsole-setup.service succeeds and fails several times on each boot
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Tue, 30 Jul 2019 10:22:38 +0000
  • Message-id: <bug-1143125-21960-NvmwtzRsag@http.bugzilla.suse.com/>
http://bugzilla.suse.com/show_bug.cgi?id=1143125
http://bugzilla.suse.com/show_bug.cgi?id=1143125#c3

--- Comment #3 from Franck Bui <fbui@xxxxxxxx> ---
Apparently systemd-vconsole-setup is only failing when spawned by udev:

[ 40.008060] pc systemd-vconsole-setup[1010]: /usr/bin/setfont failed with
exit status 65.
[ 40.026289] pc systemd-vconsole-setup[1011]: /usr/bin/setfont failed with
exit status 65.
[ 40.100634] pc systemd-vconsole-setup[1010]: Setting source virtual
console failed, ignoring remaining ones
[ 40.101557] pc systemd-udevd[858]: Process
'/usr/lib/systemd/systemd-vconsole-setup' failed with exit code 1.
[ 40.128793] pc systemd-vconsole-setup[1011]: Setting source virtual
console failed, ignoring remaining ones
[ 40.133664] pc systemd-udevd[880]: Process
'/usr/lib/systemd/systemd-vconsole-setup' failed with exit code 1.

Exit status 65 means (defined in /usr/include/sysexits.h):

* EX_DATAERR -- The input data was incorrect in some way.
* This should only be used for user's data & not
* system files.

Not sure what it means exactly for kbd but it might indicate something wrong
with the font data, which is strange since I have the same vconsole.conf (so
I'm using the same font) and can't see the issue.

Which version of systemd are you running ?

Can you try: rpm -V kbd ?

Can you also try to trigger the udev rule manually with udev debug logs enabled
?

# udevadm control --log-priority debug
# udevadm trigger --action=add -s vtconsole" ? does it also fail ?

and show the debug logs with:

# journalctl -b -o short-monotonic -u systemd-udevd PRIORITY=7

Thanks.

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >