Mailinglist Archive: opensuse-bugs (6588 mails)

< Previous Next >
[Bug 1143143] New: pdfshuffer - can be installed without a needed dependency
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Sun, 28 Jul 2019 16:18:57 +0000
  • Message-id: <bug-1143143-21960@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=1143143


Bug ID: 1143143
Summary: pdfshuffer - can be installed without a needed
dependency
Classification: openSUSE
Product: openSUSE Distribution
Version: Leap 42.3
Hardware: Other
OS: Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Other
Assignee: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
Reporter: Rolf.Breuning@xxxxxxxxxxx
QA Contact: qa-bugs@xxxxxxx
Found By: ---
Blocker: ---

Preconditions:
- I am using OpenSuse 15.1, KDE Desktop

Error:
- I installed pdfshuffler
zypper --non-interactive install pdfshuffler
This installed without complaint (same if I uninstall, install with YAST)
- On start of pdfshuffler from the command line, the program complains about a
missing/wrong PyGTK:
>pdfshuffler
PyGTK version 2.10.0 or higher is required to run this program.
No version of PyGTK was found on your system.
- After installing python-gtk
zypper --non-interactive install python-gtk
the program worked.

Result:
- I assume that the pdfshuffler rpm is missing a dependency to python-gtk which
inforces python-gtk to be installed before pdfshuffler.

Kind regards

Rolf

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >
Follow Ups