Mailinglist Archive: opensuse-bugs (6480 mails)

< Previous Next >
[Bug 954556] After upgrading from 13.2 to Leap 42.1, Mercurial chokes on files locally deleted and ignored, but changed on the remote
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Fri, 12 Jul 2019 03:26:02 +0000
  • Message-id: <bug-954556-21960-hxcgDpk4cC@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=954556
http://bugzilla.opensuse.org/show_bug.cgi?id=954556#c11

Tony Mechelynck <antoine.mechelynck@xxxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
Version|Leap 42.3 |Leap 15.1

--- Comment #11 from Tony Mechelynck <antoine.mechelynck@xxxxxxxxx> ---
In reply to comment #9:

I haven't tried to intentionally reproduce the bug. The workaround mentioned in
comment #9 works, but if I forget to delete the problematic file, and there are
upstream changes to it, "hg fetch" will pull the changes but not merge them and
I have to delete the file manually ("make" will recreate it the next time I
build) and then "update" my clone to the appropriate changeset to "merge" the
changes manually.

I suppose (and regret) that this bug will remain WONTFIX. Anyone willing and
able to solve it, feel free to REOPEN it and ASSIGN it to yourself. Or report
it to Mercurial if that's where it should be solved; but the Mercurial guys
will propably answer: "You're using an old version of Mercurial; upgrade to the
latest version first, and then we can talk business."

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >