Mailinglist Archive: opensuse-bugs (6499 mails)

< Previous Next >
[Bug 1116043] KTP Telepathy packages should be included in main repo
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Tue, 09 Jul 2019 14:22:16 +0000
  • Message-id: <bug-1116043-21960-EZ11fdUOBS@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=1116043
http://bugzilla.opensuse.org/show_bug.cgi?id=1116043#c39

--- Comment #39 from Wolfgang Bauer <wbauer@xxxxxx> ---
(In reply to Fabian Vogt from comment #38)
(In reply to Wolfgang Bauer from comment #37)
Ok, I'm pretty sure meanwhile that *nothing* is broken here.
(it should be possible to get rid of the runtime warning by installing a
"dummy" .rc file that's mostly empty)

Adding the file makes the UI complete, so something is definitely broken
without it.
Again, the mentioned .rc file is for /usr/lib64/libexec/ktp-call-ui, not
/usr/bin/ktp-dialout-ui.

The ktp-dialout-ui UI is complete without it, it is not supposed to have those
menus, AFAICT.
ktp-dialog-ui doesn't even have any code to handle the actions defined in that
.rc file.

From looking at the code, it should display an Accounts ComboBox and buttons in
its window if suitable accounts are found.
The actual call is just deferred to telepathy over D-BUS, which then will spawn
/usr/lib64/libexec/ktp-call-ui (which does load callwindowui.rc correctly
AFAICS) I assume.

I.e. there's nothing missing in the UI without that .rc file IMHO.

In any case, I didn't find a way for me to test whether it actually worked
as I don't have any way to use audio/video calls with telepathy.
Same for me.

As the delete request has been accepted meanwhile (despite my
gstreamer-plugins-qt5 build fix submission), I see no point in further
discussion here though.

Once ktp-call-ui dropped its dependency on gstreamer-plugins-qt5 or
gstreamer-plugins-qt5 becomes maintained again, ktp-call-ui can of course be
submitted again.
Sure. Unless it is still considered FUBAR (because of that runtime warning
e.g.), I suppose...

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >