Mailinglist Archive: opensuse-bugs (6499 mails)

< Previous Next >
[Bug 1116043] KTP Telepathy packages should be included in main repo
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Fri, 05 Jul 2019 07:45:59 +0000
  • Message-id: <bug-1116043-21960-uXTQF11dvd@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=1116043
http://bugzilla.opensuse.org/show_bug.cgi?id=1116043#c32

--- Comment #32 from Fabian Vogt <fvogt@xxxxxxxx> ---
(In reply to Wolfgang Bauer from comment #30)
(In reply to Fabian Vogt from comment #29)
I had to create a delete request for ktp-call-ui now (sr 713493) as it has a
hard requirement on gstreamer-plugins-qt5, which is unmaintained for a while
now and fails to build now because of GStreamer API changes.

The reason for the build failure is not an API change in GStreamer.
But gst_caps_copy() has been changed from an inline function to a macro, and
this seems to "confuse" the compiler.

The fix is rather simple though:
https://build.opensuse.org/package/view_file/home:wolfi323:branches:KDE:Qt5/
gstreamer-plugins-qt5/fix-build.patch?expand=1

So maybe we can keep it around for a bit longer?
I know that it's unmaintained, but that would buy some more time to port
ktp-call-ui away.

I doubt that's going to happen anytime soon and ktp-call-ui seems to be FUBAR
anyway, it doesn't even find its own kxmlgui5 description...

IMO it does not make sense to ship a package in this state so I'm in favor of a
drop, which means we won't need gstreamer-plugins-qt5 anymore anyway.

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >