Mailinglist Archive: opensuse-bugs (4794 mails)

< Previous Next >
[Bug 1050843] wacom-inputattach@.service: Unit name wacom-inputattach@.service is missing the instance name.
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 31 Jul 2017 10:48:50 +0000
  • Message-id: <bug-1050843-21960-GFz2IpGTSc@http.bugzilla.suse.com/>
http://bugzilla.suse.com/show_bug.cgi?id=1050843
http://bugzilla.suse.com/show_bug.cgi?id=1050843#c4

--- Comment #4 from Stefan Dirsch <sndirsch@xxxxxxxx> ---
Hmm. Still cannot reproduce that issue. I've tried installing the 0.34 RPM from
scratch. Also tried update the 0.32 from Leap 42.3 to the 0.34 from TW. And
also tried updating 0.34 to the same version of TW.

No idea what's happening on your system.

FWIW, this service file (wacom-inputattach@.service) has been removed with
TW.

-------------------------------------------------------------------
Wed May 10 12:38:22 UTC 2017 - sndirsch@xxxxxxxx

- removed support for serial input devices (fate#323262)

The issue would be explainable with the %postun of the old package

%postun
%service_del_postun wacom-inputattach@.service
test -n "$FIRST_ARG" || FIRST_ARG=$1
if [ $FIRST_ARG -le 1 ]; then
%udev_rules_update
%{_bindir}/systemctl daemon-reload >/dev/null 2>&1 || :
fi

since this is the last thing, which is running during an update. After the
file(wacom-inputattach@.service) has been removed.

Order:

%pre new package
<install/update files from new package>
%post new package
%preun old package
<remove files of old package, which are not part of new package>
%postun old package

So nothing anybody could easily fix. Still it would be a one-time issue, which
could simply be ignored.

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >
References