Mailinglist Archive: opensuse-bugs (4794 mails)

< Previous Next >
[Bug 1051286] BuildRequires: openmpi2-devel leads to choice error
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 31 Jul 2017 09:04:06 +0000
  • Message-id: <bug-1051286-21960-qo4IFJCHGk@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=1051286
http://bugzilla.opensuse.org/show_bug.cgi?id=1051286#c3

--- Comment #3 from Nicolas Morey-Chaisemartin <nmoreychaisemartin@xxxxxxxx> ---
(In reply to Adrian Schröter from comment #2)
However, what is the point of having multiple -config packages then in
openSUSE:Factory if any of them should just work? How is the user supposed
to decide?

He does not need to decide and that's the point.
It also means that the spec/packjage for OpenMPI are the same in all coming
SUSE release and do not depend on what versions are available.
If we want to have only one, from which openmpi version should we produce the
-config RPM ?
Depending on the OS release, different openmpi packages are available (openmpi1
will soon be replaced by openmpi3 for example)

The current way makes maintenance easier as we can keepo the package in sync
whatever versions are available.

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >
References