Mailinglist Archive: opensuse-bugs (4794 mails)

< Previous Next >
[Bug 1051386] New: ServiceStatus widget seems not working
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 31 Jul 2017 03:09:58 +0000
  • Message-id: <bug-1051386-21960@http.bugzilla.suse.com/>
http://bugzilla.suse.com/show_bug.cgi?id=1051386


Bug ID: 1051386
Summary: ServiceStatus widget seems not working
Classification: openSUSE
Product: openSUSE Tumbleweed
Version: Current
Hardware: Other
OS: Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: YaST2
Assignee: yast2-maintainers@xxxxxxx
Reporter: lszhu@xxxxxxxx
QA Contact: jsrain@xxxxxxxx
Found By: ---
Blocker: ---

Created attachment 734480
--> http://bugzilla.suse.com/attachment.cgi?id=734480&action=edit
Yast log

I can create a ServiceSattus widget and show it in such code:

def initialize
self.initial = false
@service = Yast::SystemdService.find("targetcli")
@service_status = ::UI::ServiceStatus.new(@service, reload_flag: true,
reload_flag_label: :restart)
end

def contents
HBox(
::CWM::WrapperWidget.new(
CWMFirewallInterfaces.CreateOpenFirewallWidget("services" =>
["service:sshd"]),
id: "firewall"
),
@service_status.widget
)
end

The service I want to manage is targetcli.service which in targetcli-fb
package.

These code can run without any errors, I can see the widget there. But When I
click "Start Now", I see targetcli.service is not running from "systemctl
status targetcli.service", "Start During System Boot" does not work as well.

I have attached the logs.

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >
Follow Ups