Mailinglist Archive: opensuse-bugs (4790 mails)

< Previous Next >
[Bug 1046990] python3-devel should also require python3
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Tue, 04 Jul 2017 15:56:30 +0000
  • Message-id: <bug-1046990-21960-YxBneh2LL0@http.bugzilla.suse.com/>
http://bugzilla.suse.com/show_bug.cgi?id=1046990
http://bugzilla.suse.com/show_bug.cgi?id=1046990#c2

Jan Matejek <jmatejek@xxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
Status|NEW |CONFIRMED

--- Comment #2 from Jan Matejek <jmatejek@xxxxxxxx> ---
python3 will definitely stay separate from python3-base (this is for reasons of
build dependencies, so that the interpreter can be built sooner than Xorg and
some other heavy stuff)

What might change is list of dependencies in python3-base, possibly even
renaming -base to python3 and the extra stuff to -full, -extras or something
along those lines.

The problem with requiring python3 from python3-devel is that it means that
there is no build shortcut around the Xorg stuff: you can get python3-devel
only after you built python3, which you only get after building Xorg, which
might very well require python3-devel.

OTOH, this is already the case with python2 so perhaps this might work.






// as a completely pointless aside, the other solution would be to not
specialcase SUSE and simply add python3 to buildrequires, which should work
just fine everywhere. oh well.

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >