Mailinglist Archive: opensuse-bugs (4790 mails)

< Previous Next >
[Bug 1046819] gparted can not initialize a new disk partition, no menu.
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Tue, 04 Jul 2017 12:24:55 +0000
  • Message-id: <bug-1046819-21960-vRZpSBuRJn@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=1046819
http://bugzilla.opensuse.org/show_bug.cgi?id=1046819#c7

Carlos Robinson <carlos.e.r@xxxxxxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
Flags|needinfo?(carlos.e.r@opensu |
|se.org) |

--- Comment #7 from Carlos Robinson <carlos.e.r@xxxxxxxxxxxx> ---
(In reply to Sebastian Parschauer from comment #5)
What did you select during installation when it asked for
* language

Spanish

* keyboard layout

USA

* user interface (KDE, GNOME, Server (text mode), Custom)

Custom, plus the two XFCE patterns. I banned plymouth.

Partition layout has a separate /usr and /home partitions and an encrypted data
partition. I do not use btrfs but ext4.

?

Which SW modifications did you do afterward and when?

I simply added some packages: gkrellm, shotwell, gparted... these brought in
several gnome packages. Within a day or two of first install. And some XFCE
applets.

Shotwell, which is a gnome tool, has menu.


Which config modifications did you do after installation?

None. Maybe some desktop customizations like disable the screensaver. Perhaps
activate sound in yast. Network worked without configuration. Added my user to
group systemd-journal to see the logs.

Originally "su -" did not work, worked after an update, automatically. Then I
tried gparted in order to try adding a reiserfs partition, and this test is
waiting.


I've selected GNOME and installed the Xfce desktop afterward from the
patterns and can't reproduce this with that setup and your steps.

AFAIK, the way how to install Xfce is to select "Server (text mode)" and to
select the Xfce desktop environment from the SW patterns afterward before
starting the actual installation. I did that, installed gparted afterward
and the menu is still there. So there is no package dependency issue.

I selected "Other", then added the two XFCE patterns. If something is missing,
then it is missing in the patterns and it is a bug.

linux-nzhv:~ # rpm -qa *parted*
gparted-0.26.1-3.3.x86_64
parted-3.1-28.1.x86_64
libparted0-3.1-28.1.x86_64
linux-nzhv:~ #

linux-nzhv:~ # gparted &
[1] 4838
linux-nzhv:~ # ======================
libparted : 3.1
======================
/dev/sdc: unrecognised disk label

[1]+ Done gparted
linux-nzhv:~ #


Lacking instructions on the YaST page or an specific XFCE click as several of
us requested, the proper way to install XFCE is the way I did it, as we were
told to do. The Text mode server installation misses too many components.


I did the same with VMware Workstation 11 installation, adding two more SCSI
disks, rebooting, doing your steps and still can't reproduce.

Can you please try with build300 and provide detailed steps from VMware
settings, each installation step, booting, config changes and actions? TIA

I'm now at build 300 via zypper dup, issue has not changed.

I will install another virtual machine and try a different way. But even if it
works, we have to find out why this doesn't. There is a bug somewhere.


Please note, if you hack your .vmx file yourself and just use the VMware
player, then I can't help you. Please try with QEMU/KVM and virt-manager
then.

Hack vmx, how? I just use the plain standard vmware GUI interface: create new
virtual machine from the GUI, install the operating system. Same system over a
decade. How would that be related?

I have no experience at all with QEMU/KVM, I would not be able to use those
tools.

(In reply to Sebastian Parschauer from comment #6)

Also always verify the sha256 sum of your installation media to avoid
strange issues. I'm still inclined to close this as invalid.

The DVD was downloaded using aria2c and the metalink, so checksum verification
is included automatically in the process.

I wrote the bugzilla after asking in the mail list, and people like Simon Lees
from SUSE told me that I was wasting their time and to write a bugzilla.


Anyway, the issue is certain: the application has lost the menu and I did not
do that. It is a bug, but maybe not in gparted itself.

Gparted is started from a terminal and doesn't report any issues.

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >