Mailinglist Archive: opensuse-bugs (4790 mails)

< Previous Next >
[Bug 1046197] rsync breaks backward compatibility, no --compress due to its external zlib.
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Sun, 02 Jul 2017 13:18:34 +0000
  • Message-id: <bug-1046197-21960-fK27advMMO@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=1046197
http://bugzilla.opensuse.org/show_bug.cgi?id=1046197#c5

--- Comment #5 from Ralf Friedl <Ralf.Friedl@xxxxxxxxx> ---
(In reply to Christian Boltz from comment #4)
Silly question - why does bundled vs. external zlib influence the
commandline parameters at all? I don't see why a user would have to use a
different commandline parameter just because an internal detail of rsync
changed.
According to this https://bugzilla.samba.org/show_bug.cgi?id=10372#c14 there is
some problem with the system libz, so the new compression scheme was created to
work with system libz. Unfortunately it is incompatible to the previous
compression. There seem to be some modifications necessary to libz to support
the previous compression.

On a side note, if rsync implements an new, incompatible compression, why not
use something more efficient, like bz2 or xz?

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >