Mailinglist Archive: opensuse-bugs (4661 mails)

< Previous Next >
[Bug 1046197] rsync 3.1.2 breaks backward compatibility with older versions
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Tue, 27 Jun 2017 18:19:49 +0000
  • Message-id: <bug-1046197-21960-IEoKJhW2C7@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=1046197
http://bugzilla.opensuse.org/show_bug.cgi?id=1046197#c1

--- Comment #1 from Tomáš Chvátal <tchvatal@xxxxxxxx> ---
That is not so brilliant idea. We have old zlib there atm 1.2.8 which contains
known CVEs and we have confirmed we forget to update this bundled one every
time it gets out of sync.

From what I can see it is used in a couple of places when using the system
version and thus token.c needs to be tweaked.

options.c
1869:#ifdef EXTERNAL_ZLIB

configure.ac
813: AC_DEFINE(EXTERNAL_ZLIB, 1, [Define to 1 if using external zlib])

token.c
408:#ifndef EXTERNAL_ZLIB
582:#ifndef EXTERNAL_ZLIB

I will check out how much work would be to build the "bundled code" together
with the external one for time being...

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >
References