Mailinglist Archive: opensuse-bugs (4661 mails)

< Previous Next >
[Bug 1045936] New: kdepim4 maintenance update conflicts in kjots and akonadi/kdepim-addons
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 26 Jun 2017 09:16:04 +0000
  • Message-id: <bug-1045936-21960@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=1045936


Bug ID: 1045936
Summary: kdepim4 maintenance update conflicts in kjots and
akonadi/kdepim-addons
Classification: openSUSE
Product: openSUSE Distribution
Version: Leap 42.2
Hardware: Other
OS: Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: KDE Applications
Assignee: opensuse-kde-bugs@xxxxxxxxxxxx
Reporter: astieger@xxxxxxxx
QA Contact: qa-bugs@xxxxxxx
CC: lbeltrame@xxxxxxx
Blocks: 1044210
Found By: Security Response Team
Blocker: ---

Having received a maintenance submission for bug 1044210:
https://build.opensuse.org/request/show/503641

The kdepim4 part of which is now in:
https://build.opensuse.org/package/show/openSUSE:Maintenance:6887/kdepim4.openSUSE_Leap_42.2_Update

it was discovered that there are a number of dependency issues with the kde4
portion that I would like to see addressed:

#1 kdepim4 sources build the kjots binary. However in Leap 42.2 the kjots
package is built from the kjots sources. The kdepim4 source package should
disable the kjots build. (We can skip releasing the kjots binary but would
prefer to have this addressed in source)

#2 kdepim4 sources build the akonadi package. This package has file conflicts
with kdepim-addons but is not marked as a package conflict:
https://openqa.opensuse.org/tests/431072#step/install_packages/12

File /usr/lib64/akonadi/contact/editorpageplugins/cryptopageplugin.so
from install of
akonadi-4.14.10-6.3.1.x86_64 (Test Updates for Leap 42.2 (standard))
conflicts with file from install of
kdepim-addons-16.08.2-1.1.x86_64 (oss)

This should be marked as "Conflicts: ".

There is bug 1000432 and bug 1000432 in that area. If any of their solutions
apply here, please include them in the maintenance update.

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >