Mailinglist Archive: opensuse-bugs (4652 mails)

< Previous Next >
[Bug 1044816] kernel 4.4.71 doesn't allow user to install Nvidia blob with nvidia-drm feature enabled
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 19 Jun 2017 14:48:51 +0000
  • Message-id: <bug-1044816-21960-eyyTopDGJv@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=1044816
http://bugzilla.opensuse.org/show_bug.cgi?id=1044816#c21

--- Comment #21 from Takashi Iwai <tiwai@xxxxxxxx> ---
(In reply to Stefan Dirsch from comment #19)
Yet another option would be to add Conflicts tag with nvidia package.

I can add Provides/Obsoletes to the NVIDIA KMP, so this won't trigger any
needed user input during installation. Of course if the customer decides to
uninstall the NVIDIA RPMs again, drm-kmp-default won't be reinstalled
automatically.

Yes, that'd be good in anyway, no matter whether we reduce the targeted devices
of supplements or not.

But, one thing to be noted is that you'll still need to reboot the system to
allow nvidia driver to be loaded.

But it won't help if user installs the nvidia stuff manually.

We can add this to the documentation. Release notes and
https://en.opensuse.org/SDB:NVIDIA_the_hard_way

Also, another concern is the conflict with AMDGPU-pro package...

Well, I'm not aware of any customers yet, who tried to install these
packages. ;-)

As a quick "fix" for nvidia, we can change the depedencies on Leap to match
SLE > and only install drm-kmp on Intel & AMD. This won't help though with
AMD's Pro > driver.

I also thought about removing the NVIDIA Device IDs from Supplements of
drm-kmp-default, but it would be a regression for many people not knowing to
install the drm-kmp-default package manually.

Strictly speaking, it's no "regression". Then user will get the very same
driver as Leap 42.2. But 4.9 drivers in general contain more fixes than 4.4
drivers especially for the recent hardwares, so it's rather "user doesn't
receive a fix".

And there are also hybrid
machines (Intel+NVIDIA), so for these this won't help anyway.

Right.

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >
References