Mailinglist Archive: opensuse-bugs (4652 mails)

< Previous Next >
[Bug 1044816] kernel 4.4.71 doesn't allow user to install Nvidia blob with nvidia-drm feature enabled
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 19 Jun 2017 05:29:37 +0000
  • Message-id: <bug-1044816-21960-p8peXz0STu@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=1044816
http://bugzilla.opensuse.org/show_bug.cgi?id=1044816#c15

Takashi Iwai <tiwai@xxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
CC| |mmarek@xxxxxxxx,
| |patrik.jakobsson@xxxxxxxx
Flags|needinfo?(rb03884@xxxxxxxxx |
|) |

--- Comment #15 from Takashi Iwai <tiwai@xxxxxxxx> ---
So, it's a problem of drm core kABI incompatibility as I expected.
We need to address it, at least for Nvidia.

The best option would be backport the changes regarding the drm core stuff up
to 4.9.x, but it'd be too big and risky at this moment, as it'll result in a
few hundreds of patches.

Another option would be to make a minimalistic patch (or patches) to add /
modify the structs in include/drm and include/uapi/drm just to satisfy Nvidia
kABI.

Yet another option would be to add Conflicts tag with nvidia package. But it
won't help if user installs the nvidia stuff manually.

Also, another concern is the conflict with AMDGPU-pro package...

A big problem right now is that I'm going to freeze kABI in this week, likely
in today. We can adapt the further change as an exception until RC2, though.
In anyway, we need a very quick resolution.

Patrik, Michal, what do you think?

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >
References