Mailinglist Archive: opensuse-bugs (4650 mails)

< Previous Next >
[Bug 1043616] New: awesome fails to start, errors in .xsession-errors-:0
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Fri, 09 Jun 2017 13:20:25 +0000
  • Message-id: <bug-1043616-21960@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=1043616


Bug ID: 1043616
Summary: awesome fails to start, errors in .xsession-errors-:0
Classification: openSUSE
Product: openSUSE Distribution
Version: Leap 42.3
Hardware: Other
OS: Other
Status: NEW
Severity: Minor
Priority: P5 - None
Component: Other
Assignee: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
Reporter: okurz@xxxxxxxx
QA Contact: qa-bugs@xxxxxxx
Depends on: 1043604
Found By: ---
Blocker: ---

## observation

Starting awesome fails with just the mouse cursor and background shown and
output in ~/.xsession-errors-:0

```
error while running function
stack traceback:
/usr/share/awesome/lib/freedesktop/desktop.lua:40: in function 'add_icon'
/usr/share/awesome/lib/freedesktop/desktop.lua:81: in function
'add_applications_icons'
/etc/xdg/awesome/rc.lua:165: in main chunk
error: /usr/share/awesome/lib/freedesktop/desktop.lua:40: attempt to call
upvalue 'wibox' (a nil value)
E: awesome: main:605: couldn't find any rc file
```


## expected result

The corresponding openQA test works fine:
https://openqa.opensuse.org/tests/latest?machine=64bit&test=otherDE_awesome&flavor=NET&distri=opensuse&arch=x86_64&version=42.3

Is the difference that I start awesome from sddm here?

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >
This Thread
  • No further messages