Mailinglist Archive: opensuse-bugs (4295 mails)

< Previous Next >
[Bug 1017189] libvirt: vbox:///session: internal error: unable to initialize VirtualBox driver API
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Wed, 31 May 2017 20:13:30 +0000
  • Message-id: <bug-1017189-21960-37t2G7Fce3@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=1017189
http://bugzilla.opensuse.org/show_bug.cgi?id=1017189#c8

James Fehlig <jfehlig@xxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
CC| |matwey.kornilov@xxxxxxxxx
Flags| |needinfo?(matwey.kornilov@g
| |mail.com)

--- Comment #8 from James Fehlig <jfehlig@xxxxxxxx> ---
(In reply to Matwey Kornilov from comment #7)
I am facing the similar issue at openSUSE Leap 42.2 with

virtualbox-5.1.22-19.15.2.x86_64 (from OSS updates)

and

libvirt 2.0.0

IMO you should have opened a new bug, but I'm fine using this one for now.

virtualbox 5.1 API is supported only starting libvirt 2.5.x.

See commit 15209649bdaa5fc995983708e47d4bd84791b228 ("vbox: add vbox 5.1 C
API header file.")

I added that commit to a branch in my home project. Can you give it a try?

http://download.opensuse.org/repositories/home:/jfehlig:/branches:/openSUSE:/Leap:/42.2:/Update/standard/

FYI, SLE12 SP2 and 42.2 share the same libvirt package. vbox is not supported
on SLE, in fact the driver is not even built for SLE. But all maintenance of
libvirt flows through SLE. After passing QA, libvirt updates are released to
the SLE update repos. A bot is configured to submit those to
openSUSE:Leap:42.2:Update automatically. Long story short: the fix will have to
wait for a future SLE12 SP2 update before appearing in
openSUSE:Leap:42.2:Update.

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >