Mailinglist Archive: opensuse-bugs (4284 mails)

< Previous Next >
[Bug 1040145] ruby2.3 package installs ruby2.1 as well
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Fri, 26 May 2017 09:34:54 +0000
  • Message-id: <bug-1040145-21960-4JHvINqc6o@http.bugzilla.suse.com/>
http://bugzilla.suse.com/show_bug.cgi?id=1040145
http://bugzilla.suse.com/show_bug.cgi?id=1040145#c2

--- Comment #2 from Dimitris Karakasilis <dkarakasilis@xxxxxxxx> ---
I enabled the "update" repo in the container (where the problem exists) and
ruby2.3 still requires ruby2.1 package.



/:/# zypper info ruby2.3
Loading repository data...
Reading installed packages...


Information for package ruby2.3:
--------------------------------
Repository : update
Name : ruby2.3
Version : 2.3.3-2.3.1
Arch : x86_64
Vendor : openSUSE
Installed Size : 555.0 KiB
Installed : No
Status : not installed
Summary : An Interpreted Object-Oriented Scripting Language
Description :
Ruby is an interpreted scripting language for quick and easy
object-oriented programming. It has many features for processing text
files and performing system management tasks (as in Perl). It is
simple, straight-forward, and extensible.

* Ruby features:

- Simple Syntax

- *Normal* Object-Oriented features (class, method calls, for
example)

- *Advanced* Object-Oriented features(Mix-in, Singleton-method, for
example)

- Operator Overloading

- Exception Handling

- Iterators and Closures

- Garbage Collection

- Dynamic Loading of Object Files (on some architectures)

- Highly Portable (works on many UNIX machines; DOS, Windows, Mac,
BeOS, and more)

/:/# zypper lr -u
# | Alias | Name |
Enabled | GPG Check | Refresh | URI
--+----------------------------------+----------------------------------+---------+-----------+---------+---------------------------------------------------------------------------------------------
1 | 28a0a9a574b284bc9c335b184013c02d | 28a0a9a574b284bc9c335b184013c02d | Yes
| (r ) Yes | Yes |
http://download.opensuse.org/distribution/leap/42.2/repo/oss/
2 | a2be8572805599e78f3498377d05d96a | a2be8572805599e78f3498377d05d96a | Yes
| (r ) Yes | Yes |
http://download.opensuse.org/repositories/Cloud:/Platform:/SUSE-Stemcell/openSUSE_Leap_42.2/
3 | update | update | Yes
| (r ) Yes | No | http://download.opensuse.org/update/leap/42.2/oss/

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >
References