Mailinglist Archive: opensuse-bugs (4297 mails)

< Previous Next >
[Bug 1040356] New: unmotivated downgrade of libopenssl1 when trying to install openQA
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Tue, 23 May 2017 11:47:36 +0000
  • Message-id: <bug-1040356-21960@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=1040356


Bug ID: 1040356
Summary: unmotivated downgrade of libopenssl1 when trying to
install openQA
Classification: openSUSE
Product: openSUSE Tumbleweed
Version: Current
Hardware: Other
URL: https://openqa.opensuse.org/tests/407183#step/openqa_w
ebui/9
OS: Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Patterns
Assignee: dimstar@xxxxxxxxxxxx
Reporter: okurz@xxxxxxxx
QA Contact: qa-bugs@xxxxxxx
Found By: ---
Blocker: ---

## Observation

openQA test trying to install openQA on last released snapshot before last
released (20170516) fails in
[openqa_webui](https://openqa.opensuse.org/tests/407183#step/openqa_webui/9)
with

```
Problem: openQA-4.4.1495306603.5c05c24-3.4.noarch requires git-core, but this
requirement cannot be provided
uninstallable providers: git-core-2.13.0-1.1.i586[openSUSE-20170516-0]
git-core-2.13.0-1.1.i86_64[openSUSE-20170516-0]
Solution 1: dowmgrade of libopenssl1_0_0-1.0.2k-3.1.i86_64 to
libopenssl1_0_0-1.0.2k-1.2.i86_64
Solution 2: install git-core-2.13.0-1.1.i586 despite the inferior architecture
Solution 3: do not install openQA-4.4.1495306603.5c05c24-3.4.noarch
Solution 4: break openQA-4.4.1495306603.5c05c24-3.4.noarch by ignoring some of
its dependencies
```

## Reproducible

Fails as it seems when trying to install a new package in 20170516 after
20170521 just got released.


## Expected result

Trying to install a new package should not need to pull in a new version. Also
libopenssl1 should have a release counter higher than the previous one on a new
package release.


## Further details

Always latest result in this scenario:
[latest](https://openqa.opensuse.org/tests/latest?flavor=dev&test=openqa_install%2Bpublish&machine=64bit&arch=x86_64&distri=openqa)

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >