Mailinglist Archive: opensuse-bugs (4295 mails)

< Previous Next >
[Bug 1040256] New: package kiwi-pxeboot: installation failure
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 22 May 2017 21:54:38 +0000
  • Message-id: <bug-1040256-21960@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=1040256


Bug ID: 1040256
Summary: package kiwi-pxeboot: installation failure
Classification: openSUSE
Product: openSUSE Distribution
Version: Leap 42.3
Hardware: Other
OS: Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Other
Assignee: bnc-team-screening@xxxxxxxxxxxxxxxxxxxxxx
Reporter: comes@xxxxxxxx
QA Contact: qa-bugs@xxxxxxx
Found By: ---
Blocker: ---

while I perform a standard installation that includes also the package
kiwi-pxeboot, a popup window appears with the message:

Installation of package kiwi-pxeboot failed.

After I click Ignore and the installation process completes I can confirm that
kiwi-pxeboot does not get installed and in /var/log/zypp/history I found this
error message:

# 2017-05-19 12:31:19 kiwi-pxeboot-9.3.3-1.3.x86_64.rpm install failed
# rpm output:
# /var/tmp/rpm-tmp.U40Wo4: line 4: /usr/sbin/groupadd: No such file or
directory
# /var/tmp/rpm-tmp.U40Wo4: line 7: /usr/sbin/useradd: No such file or directory
# error: %pre(kiwi-pxeboot-9.3.3-1.3.x86_64) scriptlet failed, exit status 127
# error: kiwi-pxeboot-9.3.3-1.3.x86_64: install failed
#
2017-05-19
13:28:47|install|kiwi-pxeboot|9.3.3-1.3|x86_64||openSUSE-Leap-42.3-0|4a4c75a04fca08cf81d4ca7471db70d25db3938a|

The problem is that kiwi-pxeboot is installed before shadow and at that time
the binaries groupadd and useradd used in the preinstall scriptlet, are not
available yet.

A possible fix is to add this line in python-kiwi.spec:

%package -n kiwi-pxeboot
Summary: KIWI - PXE boot structure
Requires: syslinux
+PreReq: shadow
License: GPL-3.0+
Group: System/Management

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >
This Thread
  • No further messages