Mailinglist Archive: opensuse-bugs (4284 mails)

< Previous Next >
[Bug 1040145] New: ruby2.3 package installs ruby2.1 as well
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Mon, 22 May 2017 11:24:14 +0000
  • Message-id: <bug-1040145-21960@http.bugzilla.suse.com/>
http://bugzilla.suse.com/show_bug.cgi?id=1040145


Bug ID: 1040145
Summary: ruby2.3 package installs ruby2.1 as well
Classification: openSUSE
Product: openSUSE Distribution
Version: Leap 42.2
Hardware: x86-64
OS: openSUSE 42.2
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Ruby
Assignee: ruby-devel@xxxxxxx
Reporter: dkarakasilis@xxxxxxxx
QA Contact: qa-bugs@xxxxxxx
Found By: ---
Blocker: ---

I'm trying to replace rvm (https://rvm.io/) in a docker image based on opensuse
42.2 with our packaged ruby 2.3. When I run `zypper in ruby2.3` I also get
ruby2.1 installed as a dependency. Not only that but ruby2.1 also becomes the
default so `ruby` is actually `ruby.ruby2.1`. I don't think ruby2.1 should be
installed in the first place so there must be something wrong with the
dependencies.

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >