Mailinglist Archive: opensuse-bugs (4283 mails)

< Previous Next >
[Bug 939456] Tumbleweed installation USB key does not boot
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Thu, 18 May 2017 14:52:28 +0000
  • Message-id: <bug-939456-21960-mSwsJh2Qnc@http.bugzilla.suse.com/>
http://bugzilla.suse.com/show_bug.cgi?id=939456
http://bugzilla.suse.com/show_bug.cgi?id=939456#c61

Steffen Winterfeldt <snwint@xxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
Assignee|dmueller@xxxxxxxx |ms@xxxxxxxx

--- Comment #61 from Steffen Winterfeldt <snwint@xxxxxxxx> ---
Ok, I've now run a few more tests on the test system available and found the
difference that makes the regular Tumbleweed iso fail.

So, finally, there are three issues:

(1) the installation sometimes ends in a signal 11, this seems to be
independent
of the rest and please open a separate bug for this

(2) while mksusecd can create dedicated usb disk images (much like Rufus in
iso mode) it should remove the iso9660 file system to avoid confusion on some
hardware - done with the patch in comment 58

(3) the Tumbleweed images kiwi creates are technically correct but as it seems
some hardware is a bit sloppy implementing the UEFI specs: while it is ok
to leave the size of the EFI image unspecified in the el torito entry, at least
some lenovo thinkpads (470s, x1 carbon) like to see the real size there; it's
'-boot-load-size 1' vs. '-boot-load-size <#of_0.5k_blocks>' for genisoimage

zhx: many thanks for helping to track this down!

Marcus, maybe kiwi should also use the real size if possible (<= 0xffff
blocks)?

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >