Mailinglist Archive: opensuse-bugs (4295 mails)

< Previous Next >
[Bug 1012140] Roundcube doesn't work with PHP7
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Thu, 18 May 2017 07:57:05 +0000
  • Message-id: <bug-1012140-21960-oL97RVS6ai@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=1012140
http://bugzilla.opensuse.org/show_bug.cgi?id=1012140#c3

Johannes Weberhofer <jweberhofer@xxxxxxxxxxxxx> changed:

What |Removed |Added
----------------------------------------------------------------------------
CC| |jweberhofer@xxxxxxxxxxxxx

--- Comment #3 from Johannes Weberhofer <jweberhofer@xxxxxxxxxxxxx> ---
This problem is a common problem we have in packaging PHP software. There are
two solutions IMHO:

Solution A, the easy way)
Package the "complete" package which is slightly larger (3.9 instead of 3.6MB).
This package includes all additional packages included with composer. IMHO the
advantage is , that exactly those package versions required by the developers
will be used and no dependencies to the different php-versions must be handled.

There is no reason for moving the contents of ./program/lib/Roundcube to
/usr/php5/Roundcube and using that. Maybe some time ago, a separate
"roundcube-framework" package has been generated.

Solution B, more complicated)
Create a php7 package for roundcube and all the packages required. Its cleaner
but requires more work. Also a "php5/php7-roundcube-framework" package
should/could then created from this package and the currently separated
"roundcube-framework" should be dropped in favour of that.

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >
This Thread
  • No further messages