Mailinglist Archive: opensuse-bugs (4295 mails)

< Previous Next >
[Bug 1039436] New: ruby2.3-rubygem-jekyll nothing provides rubygem(ruby:2.3.0:liquid:3)
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Wed, 17 May 2017 07:20:35 +0000
  • Message-id: <bug-1039436-21960@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=1039436


Bug ID: 1039436
Summary: ruby2.3-rubygem-jekyll nothing provides
rubygem(ruby:2.3.0:liquid:3)
Classification: openSUSE
Product: openSUSE Tumbleweed
Version: Current
Hardware: x86-64
OS: Other
Status: NEW
Severity: Normal
Priority: P5 - None
Component: Ruby
Assignee: ruby-devel@xxxxxxx
Reporter: franz.bergesund@xxxxxxxxx
QA Contact: qa-bugs@xxxxxxx
Found By: ---
Blocker: ---

I am trying to install jekyll either under ruby 2.2 or 2.3 and in both cases I
get the error in the title.

For ruby 2.2:

Problem: nothing provides rubygem(ruby:2.2.0:liquid:3) >= 3 needed by
ruby2.2-rubygem-jekyll-3.4.3-1.1.x86_64
Solution 1: do not install ruby2.2-rubygem-jekyll-3.4.3-1.1.x86_64
Solution 2: break ruby2.2-rubygem-jekyll-3.4.3-1.1.x86_64 by ignoring some of
its dependencies

For ruby 2.3:

Problem: nothing provides rubygem(ruby:2.3.0:liquid:3) >= 3 needed by
ruby2.3-rubygem-jekyll-3.4.3-1.1.x86_64
Solution 1: ...

In both cases jekyll is provided by "repo-oss".

"repo-oss" provides
Name : ruby2.2-rubygem-liquid
Version : 4.0.0-1.1

And jekyll requires:
rubygem(ruby:2.2.0:liquid:3) >= 3

I guess that this is a packaging bug of some kind.

In the meanwhile can I install jekyll ingore "liquid" and then installing it by
hand?

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >
This Thread
  • No further messages