Mailinglist Archive: opensuse-bugs (4295 mails)

< Previous Next >
[Bug 1039396] KDE:Frameworks5: packages depend on Qt_5.7.1_PRIVATE_API?
  • From: bugzilla_noreply@xxxxxxxxxx
  • Date: Wed, 17 May 2017 06:45:02 +0000
  • Message-id: <bug-1039396-21960-t4lKQQt0t2@http.bugzilla.opensuse.org/>
http://bugzilla.opensuse.org/show_bug.cgi?id=1039396
http://bugzilla.opensuse.org/show_bug.cgi?id=1039396#c3

--- Comment #3 from Wolfgang Bauer <wbauer@xxxxxx> ---
(In reply to Chris Riddoch from comment #2)
I was experimenting recently with other versions of Qt to try to track down
some other issues I'm having.

Well, changing Qt versions is not so easy unfortunately.
Some other packages use internal/private stuff and require the exact same
version they are built with (as you noticed).

It looks like the KDE:/Qt5 repo has 5.7 in it?

Yes.

Actually it's supposed to have the latest stable release.
But it's the devel project for Tumbleweed which also still has 5.7.1 mainly
because 5.8 has a bug that would break Plasma on Wayland completely.

5.9 is going to be released in two weeks though (hopefully without such a
problem), and will probably end up in KDE:Qt5 soon.

--
You are receiving this mail because:
You are on the CC list for the bug.
< Previous Next >
References